Wikia

Getinto3d Wiki

攝影機追蹤

討論0
32條目存在於本站
本週介紹攝影機追蹤與對位,也就是將實拍影片的攝影機動態追蹤出來,然後導入max中,讓max中的3d物體與實拍影片有相同的視角,達到對位的效果

製作流程編輯

首先介紹整個攝影機對位的大略流程,讓大家有個基本觀念,對整體作業較容易掌握
1. 拍攝實拍影片
2. 輸入電腦,利用工具軟體追蹤攝影機動態
3. 視需要在max中利用攝影機匹配(camera match)工具建立與實拍角度視野吻合的攝影機
4. 將追蹤到的攝影機動畫輸入max
5. 如果有件利攝影機匹配的話,此時要對齊輸入的攝影機到新建的攝影機,不然就要手動對齊
6. 設定場景物體的材質與燈光
7. 透過輸入的攝影機算圖

拍攝實拍影片編輯

可以用數位攝影機或是數位相機來拍攝,拍攝時要記錄場景的尺寸,例如地磚長寬,門框高度,或是階梯尺寸,如果是在綠幕背景拍攝,通常會自行貼上標誌點(marker),方便後續追蹤,我們使用一段數位相機拍攝的影片來示範,長度大約十秒鐘
圖像:132105.jpg
圖像:132104.jpg
圖像來源:http://www.cgw.com/ME2/dirmod.asp?sid=&nm=&type= Publishing&mod=Publications%3A%3AArticle&mid=8F3A7027421841978F18BE895F87F791&tier=4&id=8D691D0DBEB7478E9B95C6A38F3251E1

輸入電腦編輯

輸入電腦的影片通常都是avi檔,由於我們要用的追蹤軟體只支援tga序列,所以要利用premiere或是after effects來輸出一遍,這裡用premiere來示範
1. 啟動"所有程式->Adobe Production Premium CS3-> Premiere pro cs3"
2. 選"New Project",此時要看拍攝的影片格式來設定,如果是DV拍攝的話,要選"NTSC DV",如果是一般數位相機,要使用"custom setting",參數如圖
圖像:matchmove_19.jpg
3. 在專案清單中輸入影片,然後拖放到video 1影軌開端即可
4. 執行File->Export->Movie
5. 點選"Settings"按鈕,File Type選Targa即可
6. 選擇輸出位置並取完檔名按"儲存"等待輸出完畢

追蹤攝影機動態編輯

這裡我們利用一套免費的軟體,Voodoo Camera Tracker,官網:

http://www.digilab.uni-hannover.de/docs/manual.html#download 這套軟體雖然功能不像其他商業軟體完整,但已經可以應用在大部分的情況,所以使用這套軟體來追蹤動態

1. 啟動Voodoo Camera Tracker
圖像:matchmove_20.jpg
2. 選File->Load->Sequence(影像序列),然後指到剛剛輸出的檔案位置的第一個檔案
圖像:matchmove_21.jpg
3. 在Interlace選項可以設定影片是否是交錯掃描,通常dv影片是"interlaced",數位相機是 "not interlaced",在Move type選項是設定拍攝方式,如果是手搖鏡頭要選"Free move",如果是架在三腳架上的話要選"Rotation"
4. 按下畫面右下角的"Track"按鈕,程式便會開始自動追蹤整段影片
圖像:matchmove_22.jpg
5. 等待一段時間之後,會詢問是否校正追蹤資料,選No即可
6. 選File->Save->3D Max script來將攝影機動態輸出成Maxscript腳本指令,之後在Max裡面執行這個指令檔就可以建立攝影機以及追蹤點

輸入Voodoo攝影機動態資訊編輯

1. 執行Max腳本->Run Script運行腳本,選擇voodoo輸出的ms檔
2. 此時可以看到有一台攝影機以及大量特徵點被建立出來,從透視圖觀察特徵點,可以大略看出場景的外型
圖像:matchmove_06.jpg
3. 選擇voodoo_scene物體(綠色方框),這是所有特徵點與voodoo攝影機的父物體,我們要對他進行旋轉位移縮放,讓特徵點與場景對齊
4. 首先,在左視圖旋轉voodoo_scene物體,讓特徵點對齊場景的水平方向,再上移voodoo_scene物體,讓特徵點對齊水平線
圖像:matchmove_07.jpg
圖像:matchmove_08.jpg
圖像:matchmove_09.jpg
5. 接著在正視圖旋轉voodoo_scene物體,讓特徵點對齊水平線
圖像:matchmove_10.jpg
圖像:matchmove_11.jpg
6. 接著在上視圖旋轉voodoo_scene物體,讓特徵點對齊格線方向
圖像:matchmove_12.jpg
圖像:matchmove_13.jpg
7. 如果要跟現有模型整合比例的話,也可以透過縮放voodoo_scene物體來達成
8. 將透視圖切換成voodoo_cam攝影機視圖(在透視圖字樣上按右鍵選視圖)
9. 按Alt-B叫出視圖背景設定,選擇tga序列的第一張圖檔,並勾選下面的序列選項
圖像:matchmove_15.jpg
10. 確定之後會跳出序列控制對話窗,按"確定"使用預設值即可
圖像:matchmove_16.jpg
11. 在視圖背景設定中勾選動畫背景,長寬比選擇匹配著色輸出,按"確定"關閉對話窗
圖像:matchmove_17.jpg
12. 在主功能表"自定義->偏好設定"的視埠選單,確認勾選播放時更新背景
圖像:matchmove_18.jpg
13. 此時可以在視圖中建立基本物體模型,然後拉動時間滑塊觀察攝影機對位效果

設定場景物體的材質與燈光編輯

燈光編輯

要讓3D物體與實拍場景完美融合,通常都要透過拍攝當時現場環境的HDR(高動態範圍)圖檔來替3D物體打光,會有最佳效果,這種技術稱為"Image Based Lighting"或是"HDR Lighting",max裡面也支援hdr檔案,可以用在環境貼圖或是Skylight的色彩貼圖上
拍攝系列曝光圖檔來製作HDR檔案
圖像:002_hdr-exposures.jpg
不同的HDR檔案的打光效果
圖像:002_illum_hdri.jpg
原始max標準燈光效果
圖像:scanline.jpg
使用一張HDR貼圖當做環境光
圖像:lighting.jpg
HDR燈光效果
圖像:hdri.jpg

圖片來源: 1-2: http://www.trinisica.com/sub_learn_typedissue.asp?lv=3&mode=1&issue=002 3-5: http://www.cgarena.com/freestuff/tutorials/max/hdri-vray/

如果沒有辦法取得HDR圖檔,就要記錄或觀察實拍影片中的光源位置、光源型態,以及光源色彩,然後在3D場景中盡量重建現場的光源環境來模擬實拍影片的光影效果,兩者都需要較多實務經驗與燈光知識,才能做出令人滿意的效果
當我們模擬的光影色調與實拍無法吻合時,可以透過後製特效軟體來調整,如After Effects或Fusion,都有完整的色彩校正(color correction)功能可以改善合成結果
原始影像
圖像:plates_all.jpg
初步合成
圖像:composite_1.jpg
色彩校正後
圖像:composite_6.jpg

圖片來源:http://library.creativecow.net/articles/coots_brendan/greenscreen.php

材質編輯

製作3D與實拍合成特效,除了一般的材質設定之外,還會使用到一種特殊的材質,叫做"Matte/Shadow 無光/投影"材質,比如說,我們想讓3D物體在實拍場景的地板上打出陰影,這時就要先做出地板的3D模型,再將"Matte/Shadow 無光/投影" 材質指定給地板模型,這樣算圖的時候,地版本身就不會畫出來,而只畫出物體打在地板上的陰影
地板使用標準材質
圖像:voodoo_2.jpg
地板使用Matte/Shadow材質
圖像:voodoo_3.jpg

透過輸入的攝影機算圖編輯

算圖輸出有兩種方式,一種是完全從max合成3D與實拍背景,直接輸出成品,另一種是輸出帶alpha遮罩的3D模型影像序列,然後在後製軟體中與實拍背景結合,後者的自由度較高,還可以做進一步的色彩校正,所以建議使用第二種方式來合成

max直接合成編輯

1. 在環境選單(著色Render->環境Environment)的環境貼圖(Environment Map)指定實拍背景的貼圖序列
圖像:voodoo_1.jpg
2. 照一般輸出方式算圖即可,例如輸出成貼圖序列或是avi檔案

在後製軟體合成編輯

1. 環境選單的環境貼圖不要指定任何圖檔
圖像:voodoo_4.jpg
2. 算圖選單設定TGA序列,32bit帶Alpha遮罩(紅綠藍各8bit所以一般全彩影像是24bit,加上Alpha通道8bit所以是 32bit)
圖像:voodoo_5.jpg
圖像:voodoo_6.jpg
RGB通道
圖像:voodoo_7.jpg
Alpha通道
圖像:voodoo_8.jpg
3. 輸出完成之後,在After Effects中與實拍背景一同輸入,再進行合成輸出

Wikia里...

隨機wiki