FANDOM


本週要製做頭髮並替模型製作貼圖,主要工作有展開貼圖座標,準備素材,以及繪製貼圖,慧智貼圖會使用外部軟體,叫做3d coat,是很方便且價格合理的3d雕刻繪圖軟體

展開uv坐標編輯

貼圖是根據模型上的uv貼圖坐標來顯示在模型上,所以製作貼圖前,要先準備好uv坐標,在max中是用Unwrap UVW修改器來製作
1. 貼圖分塊
由於角色模型比較複雜,所以要拆成好幾個部份來展開uv,這裡說的拆開只是概念上的,不是真的要把模型分離開來,只要在unwrap uvw裡面指定接縫就可以了,這裡分成頭(包含脖子),手臂,手掌,身體,腿,腳掌幾個部份,示意如圖
圖像:painting_02.jpg
2. Unwrap UVW修改器
2.1 首先,先把衣服隱藏起來方便操作,選擇衣服模型,按右鍵選"Hide Selection - 隱藏目前選擇"
2.2 選擇角色模型,在修改面板移除Turbosmooth修改器,按右鍵轉換為可編輯多邊形,這樣本來半邊的模型就成為完整的模型了
圖像:painting_01.jpg
圖像:painting_03.jpg
2.3 再替模型添加Unwrap UVW修改器,接著按下UnwrapUVW開頭的"+"記號,選擇面(Face)次物體
圖像:painting_04.jpg
3. 指定接縫(seam)
3.1 首先我們要調整接縫顯示方式,讓畫面只顯示Pelt用的接縫(亮藍色),其他uv接縫(亮綠色)都不要顯示,在顯示(Display)欄位勾選不顯示接縫(Show no seams),並確認有勾選"始終顯示Pelt接縫"
圖像:painting_05.jpg
3.2 修改選單往下找到編輯接縫按鈕,按下按鈕
圖像:painting_08.jpg
3.3 在模型上單擊滑鼠左鍵選擇要切開的縫隙,不用按住Ctrl,若要取消選取才按Ctrl
圖像:painting_06.jpg
圖像:painting_07.jpg
圖像:painting_15.jpg
3.4 選擇完成之後再按一次"編輯接縫"關閉此功能
4. Pelt對話視窗
4.1 選擇需要展開的部位的所有面,如頭部跟脖子所有的面
圖像:painting_15.jpg
4.2 按下貼圖參數(Map Parameters)欄位的"Pelt"按鈕,再按下下面的"編輯 Pelt 貼圖"按鈕,會跳出Pelt對話視窗
圖像:painting_10.jpg
4.3 拖動藍色圈圈外圍的紅色方框四個角點來調整方框大小,通常是拉大
圖像:painting_11.jpg
圖像:painting_12.jpg
4.4 按下"模擬Pelt拉伸"(Simulate Pelt Pulling),每按一次就會看到UV漸漸被拉開攤平
圖像:painting_13.jpg
4.5 得到滿意結果之後,關閉Pelt貼圖參數對話窗,再按一下"Pelt"按鈕關閉Pelt功能,把攤平好的部份移到空曠處,不要跟還沒攤平的uv重疊到
圖像:painting_14.jpg
4.6 重覆此流程到其他部位上,最後會得到所有部位都攤平的uv座標
圖像:painting_16.jpg
圖像:painting_17.jpg
圖像:painting_18.jpg
圖像:painting_19.jpg
圖像:painting_21.jpg
5. uv編輯視窗
5.1 關閉了Pelt貼圖參數對話窗之後,並再按一次Pelt按鈕結束Pelt模式,畫面上就剩uv編輯視窗,可以對uv做進一步調整
5.2 視窗下方的工具欄,勾選選擇元素(Select element)可以一次選擇整個部位
圖像:painting_20.jpg
5.3 選擇任一個元素部位或數個頂點,執行工具-> 鬆弛對話框(Relax dialog),可以調整uv的形狀
5.4 全選所有部位,執行工具-> 緊縮uv(Pack UVs)可以自動將各個部份排列縮放到一張圖的大小範圍內
圖像:painting_21.jpg
圖像:painting_22.jpg
圖像:painting_23.jpg
5.5 如果發現有uv重疊的情形,有時也需要將選擇模式切換成頂點模式,然後手動移動頂點來修正
圖像:painting_31.jpg
圖像:painting_32.jpg
圖像:painting_33.jpg
6. 眼睛貼圖
6.1 我們的眼睛跟身體是不同的模型,所以要另外設定貼圖座標
6.2 選擇眼睛,添加UVW Map修改器,使用平面投影,並對齊到X軸或Z軸,按下"適配"按鈕
圖像:painting_25.jpg
6.3 選擇另一隻眼睛,重覆上個步驟
6.4 打開材質編輯器,將新的材質指定給兩隻眼睛,並指定眼睛的漫反射(Diffuse)貼圖,並記得按下在視圖中顯示貼圖的按鈕
圖像:painting_26.jpg
圖像:painting_27.jpg
7. 衣服貼圖
請參考上面Pelt的方式來展開衣服的uv座標,在畫面上按右鍵可以取消所有隱藏物體來顯示衣服,記得要先將衣服的Turbosmooth移除,再轉換成可編輯多邊形,才進行UnwrapUVW及Pelt
圖像:painting_29.jpg
圖像:painting_28.jpg

輸出模型編輯

由於貼圖要在外部軟體製作,所以我們要將模型輸出成3d coat支援的格式,3d coat支援的格式主要有3ds跟obj檔,我們這裡用obj檔來工作
1. 選擇角色模型,執行檔案->匯出選定物件(Export Selected),檔案類型選obj,輸出參數如圖
圖像:painting_30.jpg
2. 再選擇衣服模型,執行檔案->匯出選定物件(Export Selected),檔案類型選obj,輸出參數同上

使用3d coat編輯

由於大家是初次使用3d coat,所以首先我們先習慣一下他的基本操作,請啟動3d coat並選擇左邊數來第四個平面模型,作為練習之用,平面參數按"確定"使用預設值即可
圖像:painting_34.jpg
圖像:painting_35.jpg
1. 視圖操作
3d coat的試圖操作與maya相同,都是Alt加滑鼠左中右鍵的組合來操作
1.1 Alt + 滑鼠左鍵:旋轉視圖
1.2 Alt + 滑鼠右鍵:縮放視圖
1.3 Alt + 滑鼠中鍵:平移視圖
1.4 視圖下方的提示列會顯示目前工具詳細的操作方式,請多參考
2. 筆刷
接著看到畫面右邊有一直排工具按鈕,圖示都很直覺,為了清楚各個工具單獨的功能,建議每操作一個工具時,都將其他工具切換成禁用,筆刷工具跟大部分繪圖軟體一樣,用來選擇筆刷圖樣,甚至可以自己製作筆刷塗樣來繪圖,滾動滑鼠滾輪可以調整筆刷大小
圖像:painting_36.jpg
3. 深度
深度用來繪製凹凸變化,按下Ctrl繪製時會變成下凹,按下Shift繪製會平滑化
圖像:painting_37.jpg
4. 漫反射
漫反射用來繪製漫反射貼圖,可以是普通顏色,也可以讀取圖檔當做材質繪製,或是利用蒙板作質感變化,按下Shift繪製會平滑色彩
圖像:painting_38.jpg
5. 高光
高光用來繪製高光反射的程度,高光數值愈高反射愈銳利,高光透明度決定反射的亮度,按下Shift繪製會平滑高光
圖像:painting_39.jpg
6. 感壓類型
如果使用感壓筆繪圖,左上角的筆觸按鈕可以設定壓力的影響方式
7. 材質
讀取材質可以用來幫助繪圖,使用材質畫漫反射貼圖時最好將漫反射顏色設為白色,以免影響材質本身的顏色
8. 圖層
圖層操作跟Photoshop類似,可以利用多個圖層來繪圖
圖像:painting_40.jpg

繪製貼圖編輯

習慣了3d coat操作之後,便可以開始繪製我們自己的模型了
1. 輸入模型
執行文件->導入模型,選擇剛剛輸出的obj檔,先選身體檔,導入選項使用內定值,所以直接按"確定"
圖像:painting_41.jpg
2. 漫反射
2.1 首先繪製漫反射顏色,所以先將其他工具禁用,並執行對稱->沿X軸對稱,取消顯示對稱平面
圖像:painting_42.jpg
2.2 可以先用左邊的油漆桶工具填滿底色,例如膚色
2.3 接著可以讀入參考圖檔直接將圖檔畫在模型上,如眉毛跟嘴唇
圖像:painting_43.jpg
圖像:painting_44.jpg
3. 高光
可以在眼框及嘴唇部分畫上高光效果
4. 深度
可以在牛仔褲與鞋帶部分加上深度凹凸效果
5. 輸出貼圖
執行主功能表的"文件"->"輸入/輸出貼圖"->"輸出紋理貼圖"可以輸出繪製好的漫反射貼圖,其他貼圖以此類推
6. 在max中指定貼圖
在max中只要在相關材質的相關貼圖欄位指定剛剛輸出好的貼圖即可,較特別的是法線貼圖,要在凹凸貼圖欄位使用"NormapBump",然後才把輸出的法線貼圖指定給NormapBump的Normal Map欄

片狀頭髮製作編輯

片狀頭髮的製作方式與上衣類似,也是從原來模型中選擇多邊形然後分離複製成新模型,再修改形狀而成,由於時間關係,在這裡僅列出步驟供大家參考,不進行實際操作,請直接合併hair.max檔與身體對齊
圖像:painting_45.jpg
圖像:painting_47.jpg
圖像:painting_48.jpg
圖像:painting_63.jpg
圖像:painting_62.jpg
圖像:painting_61.jpg
圖像:painting_60.jpg
圖像:painting_59.jpg
圖像:painting_58.jpg
圖像:painting_57.jpg
圖像:painting_56.jpg
圖像:painting_55.jpg
圖像:painting_54.jpg
圖像:painting_53.jpg
圖像:painting_52.jpg
圖像:painting_51.jpg
圖像:painting_50.jpg
圖像:painting_49.jpg
圖像:painting_64.jpg
圖像:painting_65.jpg

睫毛製作編輯

睫毛的製作方式是分別選擇上眼眶與下眼眶的邊,然後按下"從選擇建立圖型"按鈕,選"線性",就會建立新的曲線,接著在對曲線添加擠出修改器,便可以做出睫毛來,在此也僅列出步驟供參考,hair.max裡也包含了製作完成的睫毛
圖像:painting_66.jpg
圖像:painting_67.jpg
圖像:painting_68.jpg
圖像:painting_69.jpg
圖像:painting_70.jpg
圖像:painting_71.jpg
圖像:painting_72.jpg
圖像:painting_73.jpg
圖像:painting_74.jpg
圖像:painting_75.jpg
圖像:painting_76.jpg
圖像:painting_77.jpg
圖像:painting_78.jpg

您使用了廣告過濾軟體!


Wikia通過廣告運營為使用者提供免費的服務。我們對通過嵌入廣告過濾軟體訪問網站的使用者進行調整。

如果您使用了廣告過濾軟體,將無法使用我們的服務。請您移除廣告過濾軟體,以確保頁面正常載入。